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Top Tips for Oracle Designer 6.0 
Peter Koletzke 
Millennia Vision Corporation 

It seems that Oracle Designer is a tool that everyone either loves or hates. Those who love it appreciate its rich 
repository that offers centralized system development work. They appreciate the structure that it gives for 
capturing details about a project and are able to effectively use the power of the code generators. They have also 
wrestled with and developed a satisfactory working relationship with the front-end tools. Those who hate Designer 
are confused or frustrated by its complexity and steep learning curve. They too have wrestled with the front-end 
tools but have not won. 

The good news is that the hate relationship can be avoided. That there are those in the other category is proof that 
this is possible. All it takes is training and experience. It also helps if you have a plan both for learning how to use 
Designer and for applying it to your application design and development needs. In addition, it helps to have 
practical techniques at your fingertips when you work in the repository. 

This paper presents a dozen categories of the author’s top tips to assist you, both in learning Oracle Designer and 
in applying it to a system development process. These tips concentrate on the analysis and design tools that are 
used most frequently. They should help you increase your productivity as you work with the Oracle Designer 
front-end tools and help you overcome the frustration and confusion that might put you in the "hate" category. The 
discussion assumes you are familiar with the main Oracle Designer tools and utilities and have a basic 
understanding of the makeup of the repository. It is quite likely that you will find something in this list that you 
did not know before. The web sites listed at the end of this paper contains additional tips and and a place to leave 
your own favorites for others to see. Now, on to the tips. 

Note: The tips in this paper are oriented towards Oracle Designer version 6.0, the production version that 
is current as of this writing. Designer version 6 was a minor upgrade from Designer version 2. Therefore, 
all tips in this paper will work for version 2.1 as well as for version 6.0. 

1. Do Some Planning 

Development tools like Oracle Developer have a known and usually approachable learning curve. After you install 
the software, you will be up and running in short order particularly if you have previously developed client 
applications.  

Design tools like Oracle Designer, however, have a steeper learning curve because the tool is tied closely to 
whatever methodology you choose for designing and producing your system. Therefore, you must be certain of the 
plan you will follow to develop the system before you determine how you use the tool to support that plan. Oracle 
Designer is flexible enough to fulfill the needs of diverse system development strategies. Coupled with its 
extensibility and API (Application Programmatic Interface), one could argue that it is capable of supporting 
virtually any system methodology. 

• Determine a System Design Approach. It may seem obvious, but is worth restating that if you do not know 
what steps you have to take to create the system, you will fail in the work you do in Oracle Designer. 

Therefore, the first tip is to create a plan for using the Oracle Designer tools based on how you are 
approaching the system development methodology. Once that kind of planning is done, you will have to 
answer questions like the following for your particular environment. 
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♦ How many repositories will you use?  

♦ How will developers be partitioned into different repositories and application systems?  

♦ How will definitions be shared or transferred between application systems? 

♦ Will you follow a traditional partitioning scheme by having separate application systems for 
Development, Test, and Production?  

♦ Will you use Oracle Designer-generated prototypes to show the users so they can get used to what the 
generators can produce (and not expect much more)? 

♦ What depth will you go into the repository to support your system development? 

♦ What are your critical success factors for each phase of the life cycle? 

♦ How will you know that each development phase is complete? 

♦ How much user involvement will you have in your project? 

When considering the answers to these questions, you need to take into account the human and system 
resources available to you. You also need to consider the version of Oracle Designer that you will be using. If 
it is release 2.1 or 6.0, you will need to think about application system versioning differently than if you will 
use release 6i (6.5). From all reports on the pre-production releases, Oracle Designer 6i will contain a full-
featured version-control system for repository elements that radically changes the way you approach your use 
of the repository. Therefore, the version of Designer is of key importance when designing how to partition and 
share the repository data. 

• Strategize Your Oracle Designer Workgroup. When thinking how you will use Oracle Designer, you will 
have to decide who will perform each task in the development process. You will need to determine what type 
of security you need to implement for application systems and for the repository itself. For example, will you 
have a person in the role of Oracle Designer Administrator? This person can install and perform upgrades to 
the repository, maintain the tablespaces and user accounts, and, perhaps, be in charge of what repository 
definitions are updated. This person may be the only one, for example, who can create or modify a domain that 
affects all developers. 

• Use Pre-existing Elements. Pay attention to extra elements in the Repository Object Navigator (RON). There 
are some pre-built element types that Oracle has defined. Though you may be unaware of them because there 
is no Oracle Designer diagrammer or tool that employs them, many of these are usable for your purpose. For 
example, there are elements like Document, Key Performance Indicator, Objective, Assumption, Problem, and 
Location. These can all assist you in capturing information in the repository for a specific need without having 
to use User Extensions. The help system has some sketchy information about these pre-extended elements, but 
it’s up to you to decide exactly how to use them. For example, you could use the Objectives element to store 
information about system requirements. 

• Partition Your Application Systems. You can create one application system that contains master copies of 
objects commonly used in your company, like domains, storage definitions, and reusable module components. 
This allows you to share the definitions into new application systems while keeping the administration of the 
objects in a central location. In the case of domains, the administrator would be the only person who could 
change or add to those domains. 
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2. Learn Oracle Designer 

After you have determined what your approach to developing the system will be, you will have to learn as much as 
possible about Oracle Designer and how it can fit into that approach. There are a few sources for information 
about the tools and all have their own benefits. If you skip the reading or research in any area, you may start down 
the wrong path, and not know it until you reach the wrong destination. There some important sources for 
information: 

• Read the Third-Party Books. These books are available now and give practical information from people who 
have used the product. Buy all of them as it is a small investment compared to the price of the software. These 
books can serve as reference material and resources to get you started in a particular aspect of the product. 

• Join User Groups. User groups provide list servers and conferences that give you real-world people’s views 
and experiences on what works, what doesn’t, and how Oracle Designer is used. 

• Contact Oracle Sources. Oracle sells hard copy books that document the product but these basically repeat 
information you can glean from the help system. In addition, you can get bulletins from Oracle Support and 
white papers from the Oracle web sites: in “collateral” areas at www. oracle.com and at the Oracle developers 
web site: technet.oracle.com. 

• Read the Oracle Documentation. Yes it does exist. See category 5 below, Understand the Documentation. 

3. Configure the Designer Environment 

After installing Oracle Designer, you might want to customize your environment in some of the following ways. 

• Pin the Designer API Packages. The Designer front-end tools use API packages to manipulate data in the 
repository tables. Using the Repository Administration Utility's Pin button, you can load these packages into 
the database's SGA memory to make the code more quickly available. In addition, with Oracle8, you can 
create an AFTER STARTUP ON DATABASE database event trigger that automatically pins the API 
packages and table triggers when the database is started. The trigger is owned by a user who has privileges to 
create database event triggers and has the following code: 

CREATE OR REPLACE TRIGGER after_startup_as 

   AFTER STARTUP ON DATABASE 

BEGIN 

   repos.des_util.pin_designer_api; 

END;  

The following procedure code would be created in a package DES_UTIL in the repository owner's schema. 
The DBA user that owns the trigger would have EXECUTE privileges to the package. 

PROCEDURE pin_designer_api 
AS 
BEGIN 
   -- The repository user name is hard coded. It could also be passed in as a parameter. 
   FOR obj IN 
      (SELECT NVL(ci_owner, ’REPOS’) || ’.’ || ci_name name, ci_type type 
         FROM ck_installed_objects 
        WHERE ci_pin_flag = ’Y’ ) 
   LOOP 
      IF obj.type = ’PACKAGE’ 
      THEN 
         sys.dbms_shared_pool.keep(obj.name); 
      END IF; 
      -- 
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      IF obj.type = ’TRIGGER’ 
      THEN 
         sys.dbms_shared_pool.keep(obj.name, ’R’); 
      END IF; 
   END LOOP; 
END;  

• Get the Right Equipment. A large monitor running a high resolution (at least 1280×1024 pixels) is an 
essential tool for productive use of the front-end programs. You will be more productive with Designer if you 
have a large monitor with a higher resolution. Higher resolutions often require more video memory, but you 
can set the number of colors lower (256 or higher) if your video memory is limited. You will see that there is 
more screen space for windows and you will find yourself rearranging the screen less often when you use a 
higher resolution. This advice is especially critical for tools that have multiple windows with multiple parts, 
like the Design Editor. 

• Change the Default Directory. The default directory from installation is ORACLE_HOME/bin, which is 
probably not where you want to store the files that Oracle Designer creates. More importantly, if this is on a 
network and users do not have access to write to that directory, you will fail in many activities. Change the 
“Start in” directory on the Oracle Designer window shortcut (in the Start Menu) by finding the Start menu 
directory in the Windows directory. In Win NT this is under the Profile directory for the user and in Windows 
95, it is in the Windows directory. Then select File→Properties from the menu and change the Shortcut tab's 
“Start in” property to a directory you have created for Oracle Designer work. Any file that Oracle Designer 
produces will be placed in this directory. This is a handy technique for repository installation as well because 
you will always know where to find log files produced by the utilities. 

• Bypass the Oracle Designer Launchpad Window. Some of the Designer utilities and tools have a command 
line interface that allows you to start them up and load elements directly from a Windows shortcut. This can 
be useful if you find yourself spending an extended period of time in just one tool. For example, you may be 
working only with the Entity Relationship Diagrammer for a few weeks and want to run it without starting the 
Oracle Designer launchpad window, logging into a specific user account and database, and selecting an 
application system and diagram. Instead, you can create a Windows shortcut to do all of this by using a Target 
property in the Shortcut tab such as:  

 

ORACLE_HOME/awe60.exe [login_string] [/a:appsys_name,version] [/d:diagram_id] /s 

In this syntax, awe60.exe is the Entity Relationship Diagrammer executable, "login_string" is the 
username/password@database string you normally use to log into an Oracle tool. "appsys_name,version" is 
the name of the application system and version number in the Designer repository. This is specified in the 
selection box you use to choose an application system when logging into Designer. This parameter is case 
sensitive, so be sure to use upper case. "diagram_id" is the internal ID number of the diagram you want to 
load. You can determine this by selecting the diagram name in the RON (Sets node), clicking a property in the 
Property Palette, and pressing [F5]. This will display the Property Details window that shows the Object ID of 
the diagram that you use in this command line. The "/s" indicates that you want to suppress the Designer 
splash screen. A real example of this might look like the following: 

 

c:\orant\awe60.exe scott/tiger@d703 /a:SALES,1 /d:303 /s 

The following table lists some of the Designer tools and their executable file names. While all of them use the 
login_string, "/a," and "/s" parameters, the rest of the command line syntax may vary depending on the tool. 
You can force an error message that shows the syntax for a particular tool by using an invalid parameter (like 
/z:zzz) after the executable file name and login string. Figure 1 shows this dialog. 
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Oracle Designer Tool Executable Filename 

Dataflow Diagrammer awd60.exe  

Design Editor dwfde60.exe  

Oracle Designer window des2k60.exe  

Entity Relationship Diagrammer awe60.exe  

Function Hierarchy Diagrammer afw60.exe  

Matrix Diagrammer awm60.exe  

Module Structure Diagrammer dws60.exe  

Object Database Designer dwo60.exe  

Process Modeller bpmod60.exe  

Repository Administration Utility ckrau71.exe  

Repository Object Navigator ckron60.exe  

Repository Reports ckrpt60.exe  

Server Model Diagrammer dwfdd60.exe  

Designer 6.0 Executables 

Figure 1. Invalid Syntax Dialog 

Warning: If you use this command line syntax, be sure your PC has an active password-protected screen 
saver or other security system. If someone else opens up a shortcut that you have built with these 
parameters, they will be able to determine your user ID and password for that particular database. 

• Use Preferences for Each Tool. As mentioned in the diagrammer tips above, the preferences will let you 
customize your drawings. There are also preferences for other tools like RON. In those, you can specify the 
fonts used in various dialogs, colors that indicate certain states, and default actions, such as which elements 
will be displayed when you first open an application system. 

4. Know Thy Animal Parts 

Diagrammers use certain symbols that appear in the documentation with names referring to animal parts: dog-legs, 
pig’s ears, and crow's feet. Animal-wise, there is no need to mention "bugs" in the software or the "butterflies" that 
appear in your stomach when you experience them. There are a few techniques you can use to manage these 
symbols. 

• Handle Dog-Legs. Dog-legs appear as angled lines in the Entity Relationship Diagrammer, Dataflow 
Diagrammer, Process Modeller, and Server Model Diagram. Create them on an existing line by clicking on the 
line while holding the Shift key and dragging the point out. Delete them by clicking on the extra drawing point 
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while holding the Shift key. You can create a dog-leg while drawing a new line by clicking multiple points 
between the two elements. 

• Master Pig’s Ears. The ER Diagrammer can represent a recursive relationship line where an entity has a 
relationship to itself, with a part of a circle or pig’s ear. Once drawn, you can move the relationship by 
clicking on the middle of it and moving the line that appears. You can only resize it by moving the end points. 
A pig’s ear looks better when it spans two adjacent sides, but you can place both points on the same side by 
dragging the middle of the ear and dropping the line cursor on the middle of the side. 

• Manage Crow’s Feet. Crow’s feet are the many sides of relationships, constraints, or link lines in a 
diagrammer. Keeping a scheme like “crows fly south and east” (where the many sides will be either on the top 
or left side of a relationship line) is difficult but will make the Entity Relationship Diagram easier to grasp. 
Some people prefer the upside-down version of this but it depends on your personal taste or your application 
standards. The Module Diagram does not allow this scheme, although the Server Model Diagram does. 
Category 10, Be More Productive With the Diagrammers, includes some more information you can use to 
accomplish this layout. 

5. Understand the Documentation 

The Oracle-supplied documentation consists of on-line "books" in various formats. The more familiar you are with 
the documentation set the faster you will be able to find an answer to your problem or question.  

• Read the Start Here Files. This is a series of .HTML files that you view by selecting Start Here in the Oracle 
Designer group from the Windows Start menu. This selection will open your browser and load the links to the 
main Designer Documentation page (the start.htm file located in ORACLE_HOME/cdoc71). This file 
contains the following topics: Installation, Product Overview, Tutorial, API, and Element Model. 

While some of the information in this on-line documentation is also available elsewhere (for example, in the 
API help system), this is another source of help that you can refer to if needed. 

• Look at the System Release Bulletins. Oracle ships System Release Bulletin (SRB) files with Oracle 
Designer, and these are installed when you install Oracle Designer on the client PC. There is a separate 
program group in the Start menu for these bulletins. When you select one of these entries, a text editor will 
open with the text of the file. The bulletins contain information that is not in the on-line help or other printed 
documentation, such as documentation available, dependent products, known restrictions (including bugs), 
bug fixes from previous versions, and hints, workarounds, and tips. Often the SRBs contain information that is 
otherwise not easily found or just does not exist in the on-line help system.  

• Get More Tips. If you perform a keyword search in the help system for the word “tip” you might find, 
depending on the help file you are looking at, a topic of hints for more productive use of the tool. If you need 
to see the tips for a particular tool, access the help file in that tool and perform the keyword search. If you have 
navigated to another help file (they are linked together), navigate back using the Contents topic “Access to 
other Designer help systems,” and look there for the tips. 

• Read the Migration Guide. Oracle has published a 100+ page guide in .PDF file format that addresses the 
issues you face when moving from Designer 1.x to 2.x or 6.x. Call Oracle Support's Designer group or ask 
your Oracle representative for The Oracle Designer Migration Guide, Part No. Z24581. It may also be 
available from the Oracle Support web site - MetaLink. 

• Understand the Help System. See the following section for tips on using the help system. 
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6. Understand the Help System 

The help system is your friend, but you will only get something from it if you understand how it works. Although 
you may be familiar with help system mechanisms in general, it is useful to examine Designer’s help system 
organization structure and contents before you need them. 

• Know the Structure. The Oracle Designer help system is divided into three sections that correspond roughly 
to the main functional categories of Systems Modeling, Design and Generation, and Repository Maintenance. 
The high-level topics listed in the help system are as follows: 

Modeling business system requirements Systems Modeling 

Designing and generating databases and client applications Design and Generation 

Managing the Repository Repository Maintenance 

This closely parallels the Oracle Designer opening window, which has the same categories of tools (the 
Utilities area of that window is represented by the “Managing the Repository” help system). The Generating 
Preliminary Designs opening window area (which contains the Application and Database Design 
Transformers) has no separate help topic but is included under the Systems Modeling category.  

There are links from each category to the other two categories. If you run the help system from the Oracle 
Designer opening window, another introductory help system will open. This system allows you to navigate to 
the other three help systems. There is also a separate help system for the API, which you run with a menu 
choice in the Oracle Designer group of the Windows Start menu. 

• Know the Topic Names. Within each help system, there are topics that describe the tools by function, not by 
name. This puts the emphasis on the task, not the tool. For example, in the "Managing the Repository" help 
system, there are topics for "Administering the Repository" (with the Repository Object Navigator tool), 
"Managing application systems" (RON), "Reporting on the Repository" (the Repository Reports tool), and 
"Cross-referencing Repository objects" (the Matrix Diagrammer tool). 

Normally, you do not need to interact with this structure of topics because appropriate help will appear based 
on the task you are performing. Knowing the structure is useful, though, if you need help on a particular tool 
and are not working with that tool. 

• Use Context Sensitivity. There is context-sensitive help available in most tools. Click the "?" toolbar button 
(sometimes called "What's This" help) and drop the mouse cursor on an object to get help specifically for that 
object. You can also press [F1] to display this help. If you have a question about a menu choice, click the "?" 
toolbar button and navigate to the menu item in question. 

• Exploit Word Searches. Be sure to take advantage of the help system word-search facility (the Find tab of the 
help window) if you cannot find an index entry for a particular word.  

7. Use the Design Editor Productively 

The Design Editor was new as of version 2 and was not changed significantly for version 6. It contains a large 
number of methods and utilities that version 1 experts will need to become accustomed to. Since the RON has an 
interface that is similar to the Design Editor's interface, many of the tips regarding the Navigator and Property 
Palette will work equally well in both tools. 

• Use the Wizards. The wizard (or dialog) interface in the Design Editor may seem just like an ease-of-use 
feature for those just learning the product. However, you might need them. There are some functions that can 
only be performed in the wizards, like creating audit columns in a new table definition for user and dates 
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inserted and modified. Some things work in the palette but not in the wizards, so you may need to use both. 
For ease of use, click the Switch to Palette/Dialog button in the toolbar to switch back and forth.  

In addition, some actions are easier in the dialogs. For example, building a module from scratch without using 
the diagrammer requires you to create the module, module component, table usages, column usages, and 
display elements like windows. The module dialog takes you through all those steps and ensures that the 
definitions are complete. 

• Don’t Use the Wizards. You might want to use the palette sometimes, and the dialog other times. For 
example, if you are supplying the Percent Free and Percent Used properties on a table implementation, the 
Property Palette will allow a value that equals 100, but the same settings will raise an error message in the 
dialog, as Figure 2 shows.  

Figure 2. Validation Message in Dialog from Percent Free and Percent Used 

• Display the Disappearing Menu. If a menu item or toolbar button you need to use is not enabled, check that 
you have selected the proper element. You can use the “Context Sensitive” button to get help on a menu item 
or button as described above. This should tell you what needs to be selected before that menu item or button is 
enabled. Similarly, if there is a menu missing, the window may not have cursor focus. For example, in Design 
Editor, if you click on the Navigator window, a Navigator menu will appear, but if you click the Property 
Palette window, a Properties menu replaces the Navigator window. This is true in the other tools as well. 

• Open More Than One Navigator Window. You can open more than one Navigator window for an 
application system by selecting File→Open Application and opening the same application system. You can 
change the view in this window using any of a number of techniques, and it can look quite different from the 
other Navigator window. It will act as a separate “session,” although the changes you make in one window 
will be visible in the other, separate from the first. This technique is useful when you need to bounce back and 
forth between element types, which are in different places in the hierarchy. 

 

 

• Open the Property Palette Quickly. If you close the Property Palette by mistake, press [F4] to open it again. 
This keypress also works to shift focus to the Property Palette if it is displayed. To shift back to the Navigator 
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window, press [F3]. To open another property window, pin the first one (with the Pin button), click on another 
node in the Navigator, and press [F4]. 

• Use Fast Create. If you need to create multiple elements of the same type in the Design Editor, use the Fast 
Create dialog in the Edit menu. This is a good way to get a list of definitions sketched out in the repository 
quickly. You can call up this utility after selecting the Modules node, and it will give you a list to fill in of 
module names and languages. This is the minimum amount of information needed to create a module. After 
you press the OK button, the utility will create the definitions, and you can fill in the details. 

• Show the Custom Dialog Window. Select an element type node (such as Relational Table Definitions) and 
choose Display Properties from the right-click mouse menu to quickly display the Customize dialog for that 
node. This is faster than selecting the Options menu item, as you do not need to find the element type. The 
right-click mouse menu also contains options for Sort and Filter, which work in the same way for a particular 
object node. 

• Jump to the Referenced Definition. You can cause the cursor selection to jump to the referenced element 
definition. For example, with the STU_ZIP_FK foreign key properties displayed, click on the Join Table 
property (which has a value of ZIPCODES) and select Properties→Locate Object Definition (or press 
[F12]). The cursor in the Navigator will jump to the ZIPCODES table node. If your repository is large and 
complex, this could save you a bit of searching. 

• Use the Shortcut Keys. Shortcut keys can make your work in the Design Editor much faster. For some 
operations, you can avoid searching the menu or grabbing the mouse to click a toolbar button. A full list of 
shortcut keys is available by pressing CTRL-K in the Design Editor or by selecting Help→Show Keys from 
the menu. Figure 3 shows this window. It is available in other tools as well.  

Figure 3. Shortcut Keys Help Topic 

• Quickly Create Constraints. You can create foreign key constraints by dragging and dropping in the 
Navigator. Drag the primary key table’s node and drop it on the foreign key table’s node. This will create a 
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new foreign key in the table that was the target of the drop. You still have to assign columns to this constraint, 
but the constraint will be created. There is another tip for using foreign keys in RON. Click on the blue arrow 
to the left of the foreign key name in the Navigator. The selection will jump to the table definition of the table 
to which the foreign key points. 

Warning: This drag-and-drop facility can be a problem if you accidentally drop a table on another table 
when you meant to drop it on a free workspace to create a diagram. While you can always delete the 
foreign key you accidentally create, it is best to exercise caution when performing drag and drop with 
tables. Undo will not revert a drag and drop operation. 

• Try the Guides. The guides (in the Tools menu) are worth looking at even if you consider yourself an expert, 
because they can help point out something that you may have forgotten. Therefore, you can use them as a 
checklist to review a design that you made outside the guide. Think of them as the interview mode that 
present-day tax preparation programs provide to guide you through your income tax return. These programs 
take the answers you give to questions they ask and assign them to the correct location. You may know the 
process well, but having reminders never hurts. 

• Use the Diagram for Navigation.  If you select an object in the diagram and have the Property Palette open, 
the properties for that object will appear in the Property Palette. You can also turn on tracking using the 
Navigator→Track Diagram Selection menu option. When this option is checked and you select an object in 
the diagram, the corresponding element will also be selected in the Navigator. In addition, you can select 
Utilities→Select in Other Tools, so that when you select an object in the diagram, other tools (like RON) will 
show that element as selected. 

8. Use the Utilities Productively 

The Designer utilities have a standard interface and this set of tips applies to many different utilities. 

• Start the Database Design Transformer from RON.  If you select entities in the RON Navigator, those 
entities will automatically have the In Set box checked when the Database Design Transformer (DDT) starts. 
This could save a significant amount of time if you are running the utility for a subset of the entities. Starting 
DDT from RON is also recommended when you are just getting started with Oracle Designer, or when you 
have a new team of developers. It enables you to check the output of DDT and make corrections to subsets of 
analysis-level objects in RON before all the design-level objects are created. 

• Delete Modules Quickly. If you need to start over with the Application Design Transformer (ADT) but have 
already created modules, you must delete the modules first or you will get naming conflict errors when you 
run the utility again. The fastest way to delete a group of modules is to select them in RON or the Design 
Editor and use Utilities→Force Delete. If you simply try to delete the modules, you might have to run the 
delete process a number of times, as the delete will fail on modules that are called by other names. 

• Quick Start the Database Design Capture.  An alternative way to run the Capture Server Model from the 
Database utility is to drop a definition from the Database Navigator into the Design Editor Navigator. This 
runs the utility without an opening dialog and gives you a chance to browse the outcome before saving the 
changes it makes to the repository. 

• Capture Your Database. If the number of objects to design-capture is large, you may find it easier to run the 
Capture Database utility more than once with subsets of objects. If different schemas (users) own the objects, 
you will have to run the utility once for each user. It also helps if your machine has a lot of cache disk space or 
memory and a large rollback segment. 
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• Resize Dialog Columns. In the Table Mappings tab of the DDT, as in other tab dialogs in Oracle Designer, 
you can reorder and resize the columns if you need to see more characters. For example, the values in the table 
name column may not be totally visible, but you can move the column to the left by dragging and dropping the 
table column heading. You can then resize the column by dragging the side of the heading to the left or right. 
DDT remembers the new layout the next time it’s used. Figure 4 shows this operation.  

Figure 4. Resizing Columns in the Dialog 

• Report on a Subset in Repository Reports. You can include a certain subset of elements on a particular 
Repository Report report even if the elements do not have a similar name. Some reports include a parameter 
for the name of a diagram on which the elements appear. For example, the Entity Definition report includes an 
ER Diagram parameter, which lists the existing diagrams. If you select one, Oracle Designer uses it as the 
source for the entities it reports on. Thus, suppose a diagram called ERD PERSON contains the entities 
PERSON, ORGANIZATION, and PURCHASE ORDER. You can fill in the name of the diagram in the ER 
Diagram parameter, and the report will include only the PERSON, ORGANIZATION, and PURCHASE 
ORDER. The wildcard % works here too, so if you have similarly named diagrams and specify the wildcard 
name in this parameter, Oracle Designer will report on all entities on all diagrams with names that match that 
parameter. 

9. Press All the Buttons  

All Oracle Designer diagrammers and tools have standard toolbars that vary somewhat in contents but have some 
common properties and actions. 

• Move Your Toolbars. Most toolbars are moveable as you would expect in Windows work. That is, you can 
click on the space between two buttons and move the toolbar to another side of the window or let it float 
around the screen on top of the diagram.  
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• Freeze the Button. All diagrammers in Oracle Designer allow you to freeze a drawing button so that you do 
not have to reselect it if you are drawing multiple objects of the same type. If you want to draw three 
functions, for example, you can hold down the Shift key when you click the object’s button. This freezes the 
button selection so that you can draw as many functions as you want without having to press the button for the 
particular object before drawing each one. When you want to stop placing functions, click the Select toolbar 
button. 

• Use the Graphical Preferences Buttons. You can use buttons for line, color, and font instead of having to 
choose Edit→Preferences from the menu. Select the elements you wish to color and press the appropriate 
button. 

10. Be More Productive With the Diagrammers 

There are some layout techniques that may make your activities easier in the diagrammers. 

• Use In-Place Editing. One of the new features of Designer is its in-place editing. You can often apply this 
technique to the objects in a diagram. For example, you can click once on the entity name in an Entity 
Relationship Diagram. When you click again, a field will open where you can edit the value without having to 
open the Property Palette or property dialog. Click outside the field to close it when you are done. Try this in 
other tools such as the Design Editor diagrams and Navigator window. 

• Resize the Diagram. Immediately after opening a diagram, maximize the window and change the zoom size. 
Some tools open the diagram too small, while others open the diagram too large. In any case, you will be 
needlessly scrolling or adjusting the window later if you don’t adjust the view initially. Of course, you will 
have to zoom or scroll if your diagram is large or small, but the initial action of adjusting the view will still 
save you time. 

• Lay Out Straight Constraints. In the Server Model Diagram, the easiest way to layout a set of existing tables 
is to include them without constraint lines and move the tables around to the desired locations. Then, select 
Edit→ Include from the menu to include the constraint lines. Click the Autolayout button after selecting one 
or more lines to straighten them. 

• Force a Redraw. Many non-Oracle drawing tools have a Redraw selection in the menu that will refresh the 
screen to fix any out-of-place lines or pixels. Since this feature is not in the Designer menus, you have to 
minimize the drawing window (not the outer MDI window) and maximize it. This will force a redraw.  
 
You can use another redraw trick if summary information you changed does not update the title block in the 
diagram. Select File→Print Setup from the menu, change the paper size and dismiss the dialog. Be careful of 
this, as it will redraw most of the elements and the positions may not be to your liking. You can set the page 
size back to the proper one before printing. 

• Ignore Entity Properties. One approach you might consider is to ignore the entity properties when you are 
creating the entities in the ER Diagrammer. Otherwise you will have to perform another operation to open the 
Property Palette for each entity. Then use RON in the Pre-Analysis phase to fill in the details in preparation 
for the reports and versioning tasks. This approach can accelerate your work in the ER Diagrammer and still 
provide complete entity definitions. You can use a similar strategy in other diagrammers for other elements 
throughout your development work. 

• Manipulate Diagram Definitions. You can change a diagram to a certain degree using the navigators in 
RON and the Design Editor. The navigator hierarchy contains a node for diagrams that you can expand to see 
all diagrams in that area. You can delete a diagram, change its summary information (in the Property Palette), 
or rename it using this node. 
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• Press Ctrl-F. The Process Modeller allows you to move quickly to the Customize-Graphics dialog by pressing 
Ctrl-F. In fact, many functions have shortcut keys, and you can usually see which key to press by looking at 
the label hint for the menu item. This particular shortcut, however, is a carryover from Oracle Designer 
version 1 and has no menu label hint or help system reference. 

• Switch Windows in the Process Modeller and Dataflow Diagrammer. Once you Open Up and Open Down 
on a process, the diagrammer keeps a window open for each base process. You can switch back and forth 
between them faster using the Window menu window list instead of the Open Up and Open Down menu 
items. 

• Use Autolayout Smartly. The first time you press the Autolayout button, you will not be able press Previous 
Layout to return to the previous layout but you can select Edit→Undo to go back to the previous layout. After 
you press Autolayout the second time, the Previous Layout button will be available, and you can then return to 
the previous layouts. 

• Quickly Change Relationship Properties. On the ER Diagrammer, you can quickly change the cardinality, 
optionality, or transferability of a relationship by right-clicking on the end you want to change and selecting 
from the popup menu. 

• Keep Entity Short Names Short. Although a short name for an entity can contain up to ten characters, it’s 
better to use seven or fewer, especially if you’ll be generating Oracle Developer forms from your application. 
The Database Design Transformer uses the short name as the table’s Alias property, which eventually 
becomes the block name in a generated form, and forms coding is easier if the block names are short. 

• Keep Blank Pages Away. When you select Layout→Minimize Number of Pages from the menu, blank 
pages will be removed. However, if you then save the diagram, some or all of the blank pages may return. 
Closing and reopening the diagram immediately after you save will show the diagram without the extra blank 
pages. If you do not close and reopen right after saving, the blank pages will save the next time you save the 
diagram. 

11. Use the API 

Although it may seem like an advanced feature, the API is an essential part of Oracle Designer and you will 
probably find a need to use it in many places in your Oracle Designer work. Therefore, becoming familiar with the 
API is not an optional step if you are to fully utilize the Oracle Designer repository. 

You can use the API views to query the repository in ways that the front-end tools do not provide. You can also 
use the API PL/SQL packages to safely modify the contents of the repository. The more you work with Oracle 
Designer, the more you will find the API an essential assistant. The extent to which you use it depends on your 
needs and your background in PL/SQL and SQL as these are the two languages of the API. 

• Learn the API. Documentation on this feature is contained in the on-line help system under the top level 
topic "Application Programmatic Interface" which you can also access directly by double-clicking the 
DES2API.HLP file in the ORACLE_HOME/cdoc71/help directory. 

• Find the Element ID. It is useful to have an element definition's ID when constructing an API query on 
repository data. Unfortunately, you cannot directly see the ID number for elements in RON, the Design Editor, 
or Object Database Designer. You can always find an object's ID using a SELECT statement on the API view 
for that object based on the object's name and application system's name and version. There is an easier way, 
however. Select the element in the RON or Design Editor Navigator window, click a property in the Property 
Palette, and press [F5]. A Property Details window will appear that contains the ID of the element along with 
the object type, base table name, and details of the property. 
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The Property Details window is divided into two sections. The top section (labeled "Object Details") provides 
base table and view (that is, element) information while the bottom section (labeled "Properties Details") 
shows detailed information about what is stored in the base table (that is, property information). There are also 
buttons that show further information for Model (an HTML page that displays Property Details information for 
each of the properties) and API (an HTML page that displays information about the API package associated 
with the displayed element). 

• Show Audit Columns. There are columns in all repository views called CREATED_BY and CHANGED_BY 
with corresponding date columns. You can use these to determine when the definition of a particular element 
was inserted or updated, and you can, for example, issue a query that lists all table definitions that have been 
created or changed in the past week. Click on the Property Palette in the Design Editor and select 
Options→Customize Property Palette from the menu. Check the Show Audit Properties checkbox. The next 
time you open the Property Palette you will see the audit columns as Figure 5 shows. 

• List Available Text Types. You can view a list of the text types and descriptions of those types by querying 
the RM_TEXT_TYPES view. 

• Employ User Extensibility. User Extensibility is also not an optional component of Oracle Designer for the 
same reasons that the API is not optional. If you are to fully utilize the repository, you will find elements—
such as Requirements—that are missing for your particular situation. User Extensibility solves the problem of 
missing elements by allowing you to add new element types and extra properties to existing elements. Coupled 
with the API, it allows you to do virtually anything that the Oracle Designer front-end and repository cannot 
do by default. 

Figure 5. Property Palette With Audit Columns 
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12. Print What You Need 

After taking care to input data into the repository, you will want to ensure that you can view and print the 
definitions as flexibly as possible. There are a few techniques you can use to manipulate the output to a printer. 

• Print to a File. Use the following parameters to print to a file instead of the printer or screen. 

Parameter Value 

Destination Type File 

Destination Name FILENAME.LIS 

Destination Format  Dflt 

Mode Character 

Note that if you use the name of the report as the prefix for the Destination Name file name and LIS as the 
extension, the report will appear in the Output window (View→Output Window in the menu will display that 
window). The Output Window shows the list of all reports you have printed to a file. If you double-click on 
the report name, Notepad will open up with the report loaded. If you make the Destination Format HTML or 
PDF, the file produced will be accessible with a web browser (Hypertext Markup Language) or Adobe 
Acrobat reader (Portable Document Format), respectively. In addition, if you have a version of Microsoft 
Office that has a web-enabled Word, the HTML file can be opened and modified in Word, though the file’s 
extensive use of tables can cause the Word document to be a bit unmanageable. 

• Use Fit to Page. When you print, checking the Fit to Page check box may prevent printing to a large number 
of pages. You can also use Layout→Minimize Number of Pages in the menu to get rid of blank space and 
condense the view. Another technique is to change the orientation of the page from portrait to landscape on 
the Print→Setup screen. You can also specify the number of pages on which to print using the Print dialog. 
Figure 6 shows this dialog. 

Figure 6. Print Dialog 

• Fool the Print Dialog. You can select Print Preview from the File menu to show what the printed diagram or 
list will look like. However, settings like Fit to Page and Page Title (to print the summary information) are 
available only in the dialog opened with File→Print. If you set these in the Print dialog, you have to print to 
set them. The problem is that if all you want to do is preview what will print, you do not want to print and will 
not get the Print dialog. The workaround is to select File→Print and check the Print to File checkbox. Then 
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make the other desired settings and press the OK button. A dialog will appear where you would normally enter 
the name of the file to which you wanted the list or diagram printed. If you press the Cancel button in that 
dialog, the settings you made in the Print dialog will still be set and used for your Print Preview.  

Conclusion 

This list of tips should help make your work with Oracle Designer easier. It might be a useful exercise to keep 
track of your own tips that you will come up with as you continue to work with Oracle Designer. If you have a tip 
of your own to share, you can send it to author at Peter_Koletzke@compuserve.com for publishing on the web 
sites mentioned in the About the Author section below. 
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